Не нравятся результаты поиска? Попробуйте другой поиск!
dle-faq.ru FAQ (все вопросы) Ошибка с бэкапом

Ошибка с бэкапом


     10.03.2013    FAQ (все вопросы)    1834

вопрос
Всем привет)
Сделал бэкап сайта и обновился до DLe 9.8 и сейчас не грузит базу данных через админку пишет: Ошибка: Вы пытаетесь восстановить базу данных, которая не соответствует версии скрипта. Восстановление баз данных от других версий может нарушить структуру базы данных, и привести к неработоспособности скрипта.
Помогите как можно как нибудь его залить?:

Ответил: ПафНутиЙ


Установите обратно ту версию DLE, с которой делали бэкап.

Комментарии пользователей (2)

nowheremany
193

1660 | 1292

nowheremany - 11 марта 2013 09:33 - Эксперт

Ещё можно в файле бакапа убрать первую строчку.
Но БД разные от версии к версии - соответственно получите ошибку

Благодарность принимаю тут Связь

Апельсин
3

311 | 82

Апельсин - 22 марта 2013 20:10 - Юзер

Та же ситуация была при переходе с DLE 9.4 на DLE 9.6!
Проблему решил довольно просто!
Делаю полный бэкап сайта на DLE 9.4
Делаю бэкап базы данный от DLE 4.4
Заливаю новый двиг DLE 9.6 и папки с файлами (Uploads)
Устанавливаю новую версию DLE 9.6
Бэкап базы данных заливаю через SupexDumper 2 (скачать можно с офф сайта)
Никаких ошибок дать не должно!
После перехожу к починке таблиц под новую версию движка
переходим по ссылке ваш-сайт.ру/upgrade/index.php и следуем инструкции
двиг сам создаст недостающие таблицы и строки в базе
вот впринципе и всё.Хотя я мог упустить кое что...Делал давненько это.
Делал именно так всё потому что я менял всё вплоть до шаблона сайта!

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

 17.04.2013 Alexs-Yakut  MySQL
 28.10.2013 blazer-05  MySQL