Не нравятся результаты поиска? Попробуйте другой поиск!
dle-faq.ru FAQ (все вопросы) Общие вопросы Проблемы с AJAX на DLE 9.5

Проблемы с AJAX на DLE 9.5


     07.12.2012    Общие вопросы    3046

вопрос
Здравствуйте.
У меня проблема после перехода на DLE 9.5. Например в модуле lastcomments 2.4 при наведении на комментарий не появляется облако с текстом комментария. В моделе Online (показывает посетивших сайт) такая же беда. При наведении на ни пользователя не появляется краткая информация о пользователе. В чем может быть проблема ?
Заранее спасибо.

Ответил: BR0kEN


Ваша проблема никак не связанна с AJAX и заключается она в конфликте скриптов либо в отсутствии подключения jQuery.

Комментарии пользователей (10)

serg91100
3

242 | 37

serg91100 - 8 декабря 2012 00:35 - Юзер

<script type="text/javascript" src="{THEME}/js/script.js"></script>
    
<link rel="stylesheet" type="text/css" href="{THEME}/placeholder/placeholder.css" />
<script type="text/javascript" src="{THEME}/placeholder/placeholder.javascript.min.js"></script>
<script type="text/javascript" src="{THEME}/js/jquery-min.js"></script>
<script type="text/javascript" src="{THEME}/js/shadow.js"></script>
<script type="text/javascript" src="{THEME}/js/jhideshow.js"></script>
  <script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-32599368-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

Что тут может конфликтовать?

BR0kEN
163

235 | 275

BR0kEN - 8 декабря 2012 01:28 - Эксперт

Удалите подключение jQuery:
<script type="text/javascript" src="{THEME}/js/jquery-min.js"></script>

он уже подключается в {headers} по-умолчанию.

Чтобы таких проблем не возникало, полезно открывать исходный код страницы.

serg91100
3

242 | 37

serg91100 - 8 декабря 2012 11:17 - Юзер

Удалил, но ошибка осталась.

serg91100
3

242 | 37

serg91100 - 8 декабря 2012 11:19 - Юзер

Я удалил все скрипты, которе не относятся к модулям, но ничего не изменилось.

Slavchik
114 | 67

Slavchik - 8 декабря 2012 18:38 - Юзер

у вас проблемы с хинтом. проверяйте js который используется в этих модулях и css для вывода его оформления.

serg91100
3

242 | 37

serg91100 - 8 декабря 2012 19:25 - Юзер

Проблема в том, что в одном шаблоне все работает, но стоит его сменить на другой, так появляется ошибка.
В чем проблема я понять не могу.

BR0kEN
163

235 | 275

BR0kEN - 8 декабря 2012 19:35 - Эксперт

Соберите все скрипты воедино и удаляйте по одному. Еще может быть так, что где-то вы пропустили знак ; или что-то подобное.

serg91100
3

242 | 37

serg91100 - 8 декабря 2012 19:42 - Юзер

Не помогло. Ошибок нет.

ПафНутиЙ
1065

3395 | 2433

ПафНутиЙ - 8 декабря 2012 20:49 - Админ

адрес сайта есть?

Каков вопрос - таков и ответ. Просто помните об этом.

serg91100
3

242 | 37

serg91100 - 8 декабря 2012 20:59 - Юзер

Отправил в личку. У Вас есть скайп? Так как шаблон когда меняю я отключаю сайт.

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы