Не нравятся результаты поиска? Попробуйте другой поиск!

Как правильно подключить jquery tabs


     14.02.2013    jQuery    4207

вопрос
Здравствуйте, задавал вопрос по правильному подключению Jquery но ответа так и не последовало.
Задам вопрос по другому, как правильно в DLE подключить jquery tabs ? Встроенными библиотека в DLE табы не работают, требуется подключение оригинальных jquery и jquery-ui, но при этом перестают правильно работать встроенные функции DLE, в частности модальные окна. Как быть?

Ответил: nowheremany


Если речь идет от jQuery UI tabs то...

В ДЛЕ 9.8 подключены следующие компоненты Jquery UI

jquery.ui.core.js
jquery.ui.widget.js
jquery.ui.mouse.js
jquery.ui.position.js
jquery.ui.draggable.js
jquery.ui.button.js
jquery.ui.dialog.js
jquery.ui.progressbar.js
jquery.effects.core.js
jquery.effects.blind.js
jquery.effects.fade.js
jquery.effects.highlight.js
jquery.effects.pulsate.js
jquery.effects.slide.js

Логично что надо к ним добавить uitabs, не тупо только табы выбрать.
И заменить jquery UI полученным файлом.

Комментарии пользователей (13)

maggotische
4

55 | 63

maggotische - 14 февраля 2013 18:43 - Юзер

Вот я не понимаю, уважаемый NOWHEREMANY. Вы второй раз отвечаете на мой вопрос, и второй раз абсолютно не информативно и неправильно! Зачем писать если вы не знаете? Даже если подключить полную библиотеку jquery-ui (или заменить ней стандартную) табы все равно не работают! Требуется так же подключение и оригинальной jquery библиотеки (версии 1,8,3)

maggotische
4

55 | 63

maggotische - 14 февраля 2013 18:46 - Юзер

Если речь идет от jQuery UI tabs то...

да именно о них и идет речь, подключаю их следующим образом
    $(function() {
        $( "#tabs" ).tabs();
        $( "#commblock" ).tabs();
    });

ПафНутиЙ
1065

3394 | 2433

ПафНутиЙ - 14 февраля 2013 19:00 - Админ

Загляните в отладчик браузера и сё станет ясно.
А если не ясно - поясню более простым языком.
Для того, что бы заработали jqUI табы их для начала необходимо подключить. т.к. jQueryUI это большая библиотека, разбитая на компоненты (коим и являются табы), которые можно и нужно подключать отдельно, выбрав в конструкторе нужные, которые будут использоваться на сайте.
Так что ответ вам дали совершенно верный.

Каков вопрос - таков и ответ. Просто помните об этом.

maggotische
4

55 | 63

maggotische - 14 февраля 2013 19:06 - Юзер

если правильно то почему же не работает?:) Разговор до абсурда доходит....

Если я НЕ подключаю оригинальные jquery и jquery-ui табы НЕ работают. Если подключаю только jquery-ui они тоже НЕ работают, если подключаю и jquery и jquery-ui то все работает, но начинаются проблемы с табульными окнами. Обращаю внимани ято во всех случая стандартные библиотеки jquery и jquery-ui которые входят в комплект к DLE - включены

Dymatize
6

111 | 104

Dymatize - 14 февраля 2013 18:54 - Юзер.

maggotische,
Уважаемый. У вас разве в админке табы не работают? Думаю что работают...
Значит вы просто не можете правильно подключить табы и все тут.

ПафНутиЙ
1065

3394 | 2433

ПафНутиЙ - 14 февраля 2013 19:00 - Админ

в админке не используются UI-табы

Каков вопрос - таков и ответ. Просто помните об этом.

maggotische
4

55 | 63

maggotische - 14 февраля 2013 19:01 - Юзер

Цитата: Dymatize
Уважаемый. У вас разве в админке табы не работают? Думаю что работают...
Значит вы просто не можете правильно подключить табы и все тут.

вы бы посмотрели сперва что за табы в админке, а потом говрили. Это не те табы о которых идет речь. Лишь бы написать?

maggotische
4

55 | 63

maggotische - 14 февраля 2013 19:02 - Юзер

вот кстати то о чем вы говорите

http://www.dle9.com/haki/hak-dle/922-hak-dle-skript-taby-vkladki-dlya-dle-lyuboy-versii.html
но это совершенно не то о чем спрашиваю я

nowheremany
192

1659 | 1292

nowheremany - 14 февраля 2013 19:36 - Эксперт

Цитата: maggotische
Требуется так же подключение и оригинальной jquery библиотеки (версии 1,8,3)


C какого перепуга 1.8.3, если написано - 1.10.0 (Stable, for jQuery1.6+)

Благодарность принимаю тут Связь

maggotische
4

55 | 63

maggotische - 14 февраля 2013 19:39 - Юзер

Цитата: nowheremany
C какого перепуга 1.8.3, если написано - 1.10.0 (Stable, for jQuery1.6+)

где написано? Я говорю про что что при подключении этой версии jquery все работет

maggotische
4

55 | 63

maggotische - 14 февраля 2013 19:40 - Юзер

Ссылка на jquery tabs, там же видно как они подключаются "View Sourse" у меня подключено точно так же

ПафНутиЙ
1065

3394 | 2433

ПафНутиЙ - 14 февраля 2013 19:46 - Админ

Адрес своего сайта давайте, иначе тут не о чем разговаривать.

Каков вопрос - таков и ответ. Просто помните об этом.

maggotische
4

55 | 63

maggotische - 14 февраля 2013 19:54 - Юзер

Приношу свои извинения nowheremany, после очередной попытки почему то все заработало...а то я уже волосы на себе рвать начал... Не могу понять почему до этого не подключалось

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

 04.07.2011 Mexalim  jQuery
 15.10.2011 AndreY_ZO_o  jQuery
 06.05.2013 severnake  jQuery
 07.02.2014 Бахтияр_Османов  jQuery