Не нравятся результаты поиска? Попробуйте другой поиск!
dle-faq.ru FAQ (все вопросы) Общие вопросы по PHP Как исправить ошибку Illegal string offset 'available' на PHP 5.4?

Как исправить ошибку Illegal string offset 'available' на PHP 5.4?


     25.03.2015    Общие вопросы по PHP    989

вопрос
Здравствуйте подскажите пожалуйста, как исправить Illegal string offset 'available' на PHP 5.4 и выше?
Warning: Illegal string offset 'aviable' in C:\OpenServer\domains\site.ru\engine\ajax\fileserver.php on line 93 Warning: Illegal string offset 'ttl' in C:\OpenServer\domains\site.ru\engine\ajax\fileserver.php on line 94 Warning: Illegal string offset 'aviable' in C:\OpenServer\domains\site.ru\engine\ajax\fileserver.php on line 93 Warning: Illegal string offset 'ttl' in 

сам код
$allow_group=array();
$min_ttl = $fsconfig['1']['ttl'];
foreach($fsconfig as $key => $value){
    if( $value['aviable'] ) $allow_group[]=$key;
    if( $min_ttl > $value['ttl'] ) $min_ttl = $value['ttl'];
}

Ответа пока нет


Комментарии пользователей (3)

R00t
36 | 9

R00t - 29 марта 2015 05:00 - Юзер

Синтакс. ошибка? проверьте правильность aviable => available ??

kolumb
8

203 | 46

kolumb - 29 марта 2015 08:50 - Юзер

Да нет! Там не ошибка, а предупреждение. Я так понимаю php 5.4 и выше обрабатывает по другому! Как прописать не знаю.

tonik
40 | 2

tonik - 16 августа 2015 20:34 - Юзер

та же фигня...
есть решение?

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы