Не нравятся результаты поиска? Попробуйте другой поиск!
dle-faq.ru FAQ (все вопросы) Шаблоны (TPL) Конфликт jQuery модуля микро-галереи и встроенного в шаблон всплывающего окна логина и управления профилем. DLE 9.7

Конфликт jQuery модуля микро-галереи и встроенного в шаблон всплывающего окна логина и управления профилем. DLE 9.7


     31.07.2013    Шаблоны (TPL), Стили (CSS), jQuery, Модули    2462

вопрос
Суть проблемы такова:
1. есть стандартный шаблон DLE
2. есть скачанный модуль микро-галереи работающий на jquery и css
3. когда я устанавливаю (по гайду) модуль микро-галереи то при добавлении скрипта подключения библиотек в main.tpl
перестает работать всплывающее окно логина и управления профилем.(оно, как я понял, тоже работает на jquery, но только встроенной в движок).
4. Когда я убираю скрипт подключения библиотек для микро-галереи то окно логина и управления профилем начинает опять работать как часы.
5. Из всего этого я понял что возникает конфликт между двумя разными версиями jQuery (так как в движок встроена jquery-ui 1.8.23, а модуль микро-галереи просит jQuery 1.5.2)


Следовательно: как мне убрать конфликт 2х модулей работающих на разных версиях jQuery.???

Далее код взятый из чистого main.tpl с работающим окном логина но без микро-галереи:


А вот код из main.tpl с уже добавленным скриптом подключения сторонних библиотек jQuery и микро-галереей, но с неработающим(почему-то) окном логина:


Объясните новичку что делать, очень очень прошу))))

Ответа пока нет


Комментарии пользователей (4)

arkasha206
14 | 2

arkasha206 - 31 июля 2013 20:43 - Юзер

1-Вот это
<script type="text/javascript" src="gallery/jquery.microgallery.js"></script>

замените на
<script type="text/javascript" src="{THEME}/gallery/jquery.microgallery.js"></script>

2-Если не поможет 1,попробуйте удалить
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.5.2/jquery.min.js"></script>

Если не поможет,верните обратно:D
3-Если из этого ничего не помогло,то нужна ссылка на модуль и шаблон(если в паблике)
PS:как альтернативу могу предложить вариант авторизации в новом окне(вида index.php?do=login)
http://www.dle9.com/moduli/besplatnye-moduli/2377-modul-dle-vyvoda-login-panel-na-otdelnoy-stranice.html

Voodooman
2

Voodooman - 31 июля 2013 23:38 - Юзер

все это я делал. когда я делаю первый пункт галерея криво работает, когда делаю второй пункт не работает ни галерея ни логин панель.я даже делал. уже много всего перепробовал.

может тогда поможете мне как запихнуть логин-панель в сайд-бар отредактировав вот этот код(это код логин-панели):

arkasha206
14 | 2

arkasha206 - 1 августа 2013 00:18 - Юзер

1 пункт обязательный.Это же основа галереи,а путь не правильный,тл есть вы ее не подключили.
Я думаю проще поставить модуль,который я скинул.А на место формы входа ссылку на авторизацию.
Так же проблема можкт быть из-за шаблона.Может в нем косяки.Была такая проблема,потом поковырялся в файлах стилей и все пошло,только с другим модулем.Для начала рекомендую на любом локальном сервере создать сайт и на стандартном шаблоне установить модуль.Если заработает,значит шаблон с косяками.

Voodooman
2

Voodooman - 1 августа 2013 05:46 - Юзер

_http://pcvector.net/scripts/slideshow_and_scroller/411-plagin-mikro-galerei.html
вычитал тут что этот плагин микро-галереи разраюотан под версию jquery 1.5.2 и ниже. на сайте встроена jquery версии 1,8,23 следовательно всплывающее окно логина тоже написано на 1,8,23 и при насильственном подключении через

начинает работать галерея и перестает работать всплывающее окно.

следовательно есть такой вопрос сможет ли из здешних кто-нибудь переписать плагин микро-галереи с использованием стандартов версии 1,8,23 чтобы конфликта не было?

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы