Не нравятся результаты поиска? Попробуйте другой поиск!
DLE FAQ » Вопросы КЭПу » Неисправный блок голосований после смены шаблона?

Неисправный блок голосований после смены шаблона?


     10.04.2017    Вопросы КЭПу    323

вопрос
Здравствуйте. Установить чистую DLE и блок голосований был в норме. Затем я поменял шаблон, удалил стандартное голосование, аля "Оцените работу.." и поставил своё. Когда я зашёл на страницу, то увидел "это":
Неисправный блок голосований после смены шаблона?

То есть, кнопок выбора вариантов нету и другие мелочи. Создавал голосование по дефолтному голосованию. Вот:
Неисправный блок голосований после смены шаблона?

Я быстро поменял обратно на дефолтный шаблон, но эта ошибка осталась. Обновлял через Shift+F5, чистил кэн, но пробел остался. Я так понял, что ошибка не в шаблоне, а в коде?

Ответил: КЭП


Неисправный блок голосований после смены шаблона?

— Тогда мы идём к вам!

9 комментариев

TheASTRO
Юзер

TheASTRO - 10 апреля 2017 18:50 -


Первый скриншот

TheASTRO
Юзер

TheASTRO - 10 апреля 2017 18:51 -


Второй скриншот

Cartmont
Юзер

Cartmont - 10 апреля 2017 19:17 -

Если сначала все работало, значит должно работать и сейчас. Попробуйте заново изменить варианты ответа, у меня такое было когда-то, из-за копирования ответов, отображалось все как один вариант.

Так же причина может быть в нестандартном radio.

TheASTRO
Юзер

TheASTRO - 10 апреля 2017 19:34 -

В главном шаблоне временно установил styles.css из Default шаблона. неисправность осталась. Какой-то модуль может это сделать?

TheASTRO
Юзер

TheASTRO - 10 апреля 2017 19:51 -


Проблема реально в движке. Я заглянул в базу даных и увидел, что дефолтное голосование(созданное установщиком) и мною отличаются. На скриншоте видно, в чём проблема. Ошибки с моей стороны нету, так как все файлы чистые, а шаблон к админпанели не относится.
Ошибка в тэгах <br> и </br>

Cartmont
Юзер

Cartmont - 10 апреля 2017 20:25 -

хд, br так не закрывается, это не парный тег. Используется или <br> или <br />

TheASTRO
Юзер

TheASTRO - 10 апреля 2017 20:39 -

Прошу прощения, отпечатался, я имел введу <br />. И да, об этой ошибке написал на форум движка. Буду ждать ответа, если что-отпишу.

Cartmont
Юзер

Cartmont - 10 апреля 2017 21:57 -

а попыток стилизовать радио кнопки не было? Если были - это причина #1

TheASTRO
Юзер

TheASTRO - 10 апреля 2017 22:14 -

Кстати, как выяснилось, с радиокнопками всё впорядке. Это ее первое состояние. Проблема именно в генерации голосования.

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

наверх