Не нравятся результаты поиска? Попробуйте другой поиск!
DLE FAQ » Все вопросы » Общие вопросы » Не горит зеленым HTTPS нет замочка почему?

Не горит зеленым HTTPS нет замочка почему?


     01.10.2016    Общие вопросы, Хаки, Ламерские вопросы    1240

вопрос
Привет всем!
Добавил сайт в cloudflare
включил там SSL
сделал правила для https для сайта

в .htaccess прописал:
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI}


в итоге https:// - горит серым а не зеленым что не так?

Ответа пока нет


13 комментариев

progressive
Юзер

progressive - 1 октября 2016 06:21 -

Обратил внимания замок зеленым появляется в начала на одну миллисекунду а потом серым становится https

progressive
Юзер

progressive - 1 октября 2016 06:29 -


делал всё как тут: HTTPS

progressive
Юзер

progressive - 1 октября 2016 06:37 -

Security Overview
This page is not secure.

Читал где то что старые ссылки картинки на http
Из за этого не грузит Https

Блин уже не знаю куда лезть)))

Читал: FIX HTTPS

progressive
Юзер

progressive - 1 октября 2016 07:05 -

Сохранил всю базу в единый sql файл и через блокнот сделал замену http:// на https://

Помогло!

progressive
Юзер

progressive - 1 октября 2016 07:40 -

Вопрос в следующем, сейчас через раз зеленый замок поевляется значит где то всё равно осталась ссылка с HTTP каким способом мне её найти? подскажите пожалуйста!

progressive
Юзер

progressive - 1 октября 2016 08:46 -

Все сделал, остался профиль пользователя ну там всё ок! не могу понять в чём проблема? мож где что поменять? в движке DLE ?

progressive
Юзер

progressive - 1 октября 2016 08:54 -


в /addnews.html
Как исправить?
Проблема произашла

DroT
Юзер

DroT - 3 октября 2016 12:38 -


Ты в настройках скрипта ссылку сайта сделал https://? это что на главной странице в настроках

progressive
Юзер

progressive - 1 октября 2016 09:00 -

Такая проблема именно с froala editor почему то! с bbcodes и с TinyMCE тоже всё ок!

как поправить? froala editor для HTTPS

Dodo
Юзер

Dodo - 1 октября 2016 10:09 -

Скорее всего, это так называемый "Mixed Content" из-за того, что редактор грузит часть своих ресурсов не по HHTPS, а по HTTP. Запустите фаербаг или инспектор в Хроме, переключитесь на отображение сетевых запросов, и вы сможете увидеть, что именно грузится по http:// на HTTPS странице.
+ гляньте настройки сайта в админке - адрес сайта должен быть указан с https.

Ойбек
Юзер

Ойбек - 1 октября 2016 10:35 -

Лучше использовать ссылки внутренние вот так:

<a href="http://name.com/sublink">Текст</a>
можно заменить на
<a href="/sublink">Текст</a>

А если используете внешние ссылки:

<a href="http://domen.com/i/">Перейти</a>
можно заменить на вот эту
<a href="/engine/go.php?url=сюдахешдомена>Перейти</a>

Помню были ссылки ввиде: /engine/go.php?url=heshcode которые направляли в dle-news

Artyom91
Юзер

Artyom91 - 1 октября 2016 16:11 -

F12 нажмите и покажите console.

progressive
Юзер

progressive - 4 октября 2016 07:34 -

Всё норм прописал?
.htaccess
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://site.ru%{REQUEST_URI} [R,L]
RewriteCond %{HTTP_HOST} ^www.site.ru [NC]
RewriteRule ^(.*)$ https://site.ru/$1 [R=301,L]

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

наверх