Не нравятся результаты поиска? Попробуйте другой поиск!
DLE FAQ » Все вопросы » Общие вопросы » Проблемы с сайтом после переноса на виртуальный сервер. Как исправить?

Проблемы с сайтом после переноса на виртуальный сервер. Как исправить?


     28.01.2017    Общие вопросы, Ламерские вопросы    435

вопрос
После переноса сайта на не открывается страница полной новости. Выводится такая ошибка
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@goldmult.ru and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apache/2.2.15 (CentOS) Server at goldmult.ru Port 80


Все остальные страницы работают нормально.

Ответил: Yamakasi


проблема была в настройках php и конфига сервера...
при переезде или после установки, всегда настраивайте под себя настройки/конфиг, тут дело было в php конфиге однозначно...

15 комментариев

Morello
Юзер

Morello - 28 января 2017 18:01 -

сайт goldmult.ru

Morello
Юзер

Morello - 28 января 2017 18:15 -

Еще заметил, что при смене шаблона сайта на любой из стандартных все работает.

Апельсин
Юзер

Апельсин - 29 января 2017 01:17 -

перестроение публикаций сделай. Проверь, если внутри папки шаблона присутствуют файлы htaccess

как вариант - не правильно залил базу данных. залей через супекс дампер.

Morello
Юзер

Morello - 29 января 2017 11:43 -

Базу вроде залил правильно, ведь с другими шаблонами все пашет, перестроение публикаций сделал, не помогло. Удалял файл .htaccess в папке шаблона. Ничего не помогло.

Morello
Юзер

Morello - 29 января 2017 12:00 -

Вот содержимое файла error.log

Yamakasi
Юзер

Yamakasi - 29 января 2017 15:53 -

ну для начала https://yandex.ru/search/?text=500%20%D0%BE%D1%88%D0%B8%D0%B1%D0%BA%D0%B0%20%D1%81%D0%B5%D1%80%D0%B2%D0%B5%D1%80%D0%B0&lr=194

вбейте в поиск, у вас 500 ошибка валиться, если при смене шаба других пашет, в шабе есть хтач кривой!! или права или другие грабли! капайте глубже, хорошо посмотрите ещё внимательно, какой хтач блокирует или кривой!

если что в ЛС пишите, попробую глянуть...

Yamakasi
Юзер

Yamakasi - 29 января 2017 16:02 -

ещё http://dle-news.ru/tips/770-pravila-rewrite-dlya-podderzhki-chpu-na-serverax.html

Установка: Распакуйте файл nginx rewrite rules.txt из архива, скопируйте содержимое файла с правилами в свой файл конфигурации nginx.conf. Внимание данные правила действительны только для сервера Nginx standalone, если вы используете связку из Nginx и Apache, то использовать нужно стандартные правила, которые идут с архивом дистрибутива.


https://cloud.mail.ru/public/GcWa/BKNF52uxi

Morello
Юзер

Morello - 29 января 2017 23:24 -

1) Удалил все файлы .htaccess из папки шаблона - не помогло
2) Сервер работает на Nginx и Apache, PHP скрипты обрабатываются через Apache.
3) Права вроде правильно выставлены
4) Пару раз удавалось перейти на страницу новости:
Первый раз это получилось когда менял права корневой папки на 755
Второй раз во время процесса отключения Nginx на сервере.

Yamakasi
Юзер

Yamakasi - 30 января 2017 01:44 -

ответил в ЛС, но я полазил по Вашему сайту и сразу видно, то что сам сервер или хост что у Вас там, кароч не настроен!!! грубо говоря есть сильные ограничения...

например вы говорите все страницы нормально работают, а увы нет! кароч если не заходить на полную новость (не создавая запрос и нагрузку так сказать), а сразу в архив пойти, то вроде всё гуд и если на класс нажать, также, но если пойти на статическую страницу то эффект через раз, так как там меньше запросов на сколько я знаю. спецы подправят.
далее кароч я заметил если даже попутно нажать например на пару страниц или же на полную пусть и уже пробовать по архиву лазить или годам у Вас там, хотя ранее я успешно открывал - то уже не откроется будет висеть!

настройте нормально, обратитесь в техподдержку, явно криво настроено!!!

Yamakasi
Юзер

Yamakasi - 30 января 2017 01:55 -

ещё сами внимательно свои логи посмотрите. и пробуйте гуглить! я не спец прям, но кажется у Вас настроено криво! само железо... и так понимаю база с другого сервера чтоль у Вас берётся...

а так погуглите логи свои, ответов куча, которых ну минимум можно пробовать тыкать...

Morello
Юзер

Morello - 30 января 2017 11:15 -

База находится на этом же сервере

lutskboy
Юзер

lutskboy - 30 января 2017 10:53 -

не поддерживает RewriteEngine .htaccess на хостинге
попробуйте в админке отключить чпу

Morello
Юзер

Morello - 30 января 2017 11:11 -

На этом же сервере у меня находится еще один сайт goodgamebb.ru. Там вроде все работает

Morello
Юзер

Morello - 30 января 2017 11:13 -

И отключение ЧПУ не помогло

Yamakasi
Юзер

Yamakasi - 30 января 2017 15:09 -

всё пациента вылечили))) ток конечно же лучше до настроить весь сервер ему)) так сказать правильно, чтобы улетал в небеса)))

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

наверх