Не нравятся результаты поиска? Попробуйте другой поиск!
DLE FAQ » Все вопросы » Общие вопросы » Как вернуть старую карту сайта на DLE 15.2?

Как вернуть старую карту сайта на DLE 15.2?


     25.08.2022    карта сайта    Общие вопросы, Модули    167

вопрос
В DLE 15.2 пересмотрена логика создания карты сайта. Вместо единого файла - целых 4. Вопрос: есть ли возможность обновить движок без обновления модуля карты сайта или использовать новую версию со старым модулем карты. То есть, как сделать, чтобы вся карта генерировалась и обновлялась так, как было раньше - в одном файле sitemap.xml ?

Ответа пока нет


7 комментариев

lutskboy
Эксперт

lutskboy - 25 августа 2022 12:09 -

в 15.2 замените engine\inc\googlemap.php и engine\classes\google.class.php со старой версии
если не работает я не виноват

sendinfo
Юзер

sendinfo - 25 августа 2022 22:13 -

попробовал. не работает.

TeraMoune
Эксперт

TeraMoune - 25 августа 2022 23:38 -

Я тоже попробовал, и результат противоположен вашему. Заменил файлы с 14 версии. Ниже не было, да и сомневаюсь, что там будут сильные различия. Проверил несколько раз.

sendinfo
Юзер

sendinfo - 26 августа 2022 08:07 -

перепроверил ещё раз. работает. спасибо за помощь!

deadluk
Юзер

deadluk - 25 августа 2022 14:11 -

В DLE 15.2 пересмотрена логика создания карты сайта.

а в чём проблема для Вас использовать 4 файла? места на диске мало?)

sendinfo
Юзер

sendinfo - 25 августа 2022 22:10 -

есть плагин, который корректно взаимодействует только со старой картой сайта. это первое. а второе, чисто субъективное мнение - перемудрили с картой разработчики. сколько видел скриптов - везде карта сайта одним файлом.

TeraMoune
Эксперт

TeraMoune - 25 августа 2022 23:33 -

Вот моё субъективное мнение, то что вам неудобно и вы не понимаете сути изменений, или ваши плагины в друг перестали корректно работать не значит, что разработчики перемудрили. А еще не стоит смотреть на других и сравнивать с чем либо. Как раз напротив, это ваше "везде" где вы видели может просто отстают и не развиваются.

По хорошему если плагин перестал корректно взаимодействовать, его стоит обновить в соответствии с изменениями, а не бросаться возражениями и высказывать недовольства.

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

наверх