Не нравятся результаты поиска? Попробуйте другой поиск!
DLE FAQ » Все вопросы » jQuery » Как правильно обновить jquery?

Как правильно обновить jquery?


     23.02.2016    Все вопросы » jQuery    1124

вопрос
Понадобилось обновить jQuery библиотеку в движке. (Со старой версией bootstrap.js работать не хочет)
Обновил, вроде всё в порядке, но потерялись стили модальных окон, а именно кнопок и окно нельзя перемещать мышкой
Как правильно обновить jquery?


со старой версией jQuery все отображается нормально, но не работает bootstrap.js
Как правильно обновить jquery?


Кто нибудь знает что можно сделать?

Ответа пока нет


5 комментариев

WIGGO
Юзер

WIGGO - 23 февраля 2016 22:33 -

DLE 10.0

nowheremany
Эксперт

nowheremany - 24 февраля 2016 13:47 -

Jquery - Js движок, Jquery UI - компоненты для Jquery со своей версткой.
Что вы обновили? с какой на какую версию? И зачем?

По идее правильно обновить Jquery - нужно в связке с Jquery UI. Скопируйте engine/classes/js с 10.6 наприме, и JQueryUI CSS классы с шаблона от 10.6 engine.css

Благодарность принимаю тут Связь

WIGGO
Юзер

WIGGO - 24 февраля 2016 15:00 -

Сделал как Вы сказали. Скопировал папку js и обновил engine.css в шаблоне. Все работает, но опять такая же проблема, стиль кнопок исчезает.
Цитата: nowheremany
И зачем?

Со старым не хотят работать плагины bootstrap и jasny-bootstrap.
Если в main.tpl подключить
 <script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.4/jquery.min.js"></script>

плагины работают, а вот окна в dle не пашут. Плагины очень нужны

nowheremany
Эксперт

nowheremany - 24 февраля 2016 15:49 -

Для Бутстрапа достаточно JQuery 1.11.0, так же как и для jasny-bootstrap. В main.tpl нельзя добавлять ещё одину загрузку JQuery, он уже добавляется в {headers}

Благодарность принимаю тут Связь

WIGGO
Юзер

WIGGO - 24 февраля 2016 16:30 -

я знаю, что этого ему достаточно, но в самом dle стояла версия 1.8.3.
Как проблему с кнопками решить, знаете?

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

наверх