Не нравятся результаты поиска? Попробуйте другой поиск!
DLE FAQ » Все вопросы » jQuery » Как заставить работать всплывающие окна на jQuery v3?

Как заставить работать всплывающие окна на jQuery v3?


     20.09.2020    jquery, dle 13.3    jQuery, Ламерские вопросы    125

вопрос
Не могу заставить работать DLE 13.3 c jQuery v3 (из настроек скрипта)

Выдает
Uncaught TypeError: r.getClientRects is not a function

и ссылается исключительно на js файлы движка
как следствие не работаю поп апы (разные темы оформления, толку ноль)

как подружить DLE с jQuery v3?

PS не помог

PPS полный код ошибки из консоли выглядит так

jquery3.js?v=27:2 Uncaught TypeError: r.getClientRects is not a function
    at k.fn.init.offset (jquery3.js?v=27:2)
    at t.refresh (waypoints.js?v=27:1)
    at t.<anonymous> (waypoints.js?v=27:1)
    at Function.each (jquery3.js?v=27:2)
    at refresh (waypoints.js?v=27:1)
    at Function.n.<computed> [as waypoints] (waypoints.js?v=27:1)
    at t (waypoints.js?v=27:1)

Ответил: LazyDev


Обновите jQueryUI до 1.12.0 или выше.

3 комментария

portak
Юзер

portak - 20 сентября 2020 17:55 -

При переключении в админке на v3 на сайте уже подгружается файл jqueryui3, а там указана версия jQuery UI - v1.12.1 - 2019-08-12, то есть по сути уже сам дле при выборе третьей версии подсовывает мне обновленный UI, или я не понимаю?

LazyDev
PHP-developer

LazyDev - 20 сентября 2020 19:14 -

portak, подключите следующий скрипт. Он для миграции с версий ниже. https://github.com/jquery/jquery-migrate
https://code.jquery.com/jquery-migrate-3.0.0.min.js

Мой блог: LazyDev.pro

Если мне не интересен вопрос - не помогаю, и за этим по контактам прошу не писать.

portak
Юзер

portak - 21 сентября 2020 17:55 -

"PS не помог" было именно про мигрейт, забыл обернуть строчку в тег, ситуация не менялась даже с мигрейтом

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

наверх