Не нравятся результаты поиска? Попробуйте другой поиск!
DLE FAQ » Все вопросы » Общие вопросы по вёрстке » Как правильно прописать доп. поля в fullstory?

Как правильно прописать доп. поля в fullstory?


     09.09.2016    Общие вопросы по вёрстке, Шаблоны (TPL), Стили (CSS)    885

вопрос
Здравствуйте ребята, Помогите пожалуйста решить вопрос, вывел доп. поля в шаблон FullStory (Полная новость).
Поля выводятся отлично только вот какая проблема, когда поле не заполнено оно оставляет пробелы, пясняю с примером: Допустим у нас есть 3 доп поля (Дом 1, Дом 2, Дом 3) если все поля заполнены то все отлично а если допустим заполнено первое и третье (Дом 1, Дом3) то второе отстается пустым но оно выводится с пробелами и получается между ними пробел ( пустая строка ). Вопрос: как сделать так что бы если доп поле к примеру Дом 2 остается пустым то поле Дом 3 смещается выше и занимает позицию 2го доп поля? ( Скриншот прилогаю).

Ps. Заранее извиняюсь если вдруг не внятно или не корректно задал вопрос.. за всю историю в первые где либо в инете задаю вопрос, Спасибо всем кто даст конкретные ответы!
Как правильно прописать доп. поля в fullstory?

Ответил: vitnet


У вас в админ панеле в разделе "Шаблны ..." есть ссылка на документацию по движку, там все написано.

4 комментария

keyline
Юзер

keyline - 9 сентября 2016 15:38 -

Покажите код полной версии шаблона, скорей всего не правильно проставлены теги относительно вашего html

Proff
Юзер

Proff - 9 сентября 2016 15:54 -

У вас в админ панеле в разделе "Шаблны ..." есть ссылка на документацию по движку, там все написано.

Меня кстати всегда раздражало в этой документации - наличие пробелов до и после xfvalue_x (и пр.):
[xfgiven_x] [xfvalue_x] [/xfgiven_x]


markin8404443, проверь допполе Дом 2, не вбил ли ты туда пробелы по умолчанию. Затем глянь в html, что бы было не:
[xfgiven_dom2] [xfvalue_dom2] [/xfgiven_dom2]<br />

а:
[xfgiven_dom2] [xfvalue_dom2] <br />[/xfgiven_dom2]


Ошибка наверняка примитивная.

markin8404443
Юзер

markin8404443 - 9 сентября 2016 16:11 -

Цитата: Proff
markin8404443, проверь допполе Дом 2, не вбил ли ты туда пробелы по умолчанию. Затем глянь в html, что бы было не:
[xfgiven_dom2] [xfvalue_dom2] [/xfgiven_dom2]<br />
а:
[xfgiven_dom2] [xfvalue_dom2] <br />[/xfgiven_dom2]

Ошибка наверняка примитивная.


Спасибо вам большое! Действительно ошибся с
[xfgiven_dom2] [xfvalue_dom2] [/xfgiven_dom2]<br />
а:
[xfgiven_dom2] [xfvalue_dom2] <br />[/xfgiven_dom2]

Поменял местами <br/> и все встало на свои места!
Еще раз спасибо!

AVTemon
Юзер

AVTemon - 23 апреля 2017 17:56 -

Кто нибудь пробовал сделать превью видео??? Чтоб при загрузке видео, выводились скриншоты и вместо пустой картинки, был скрин из видоса
Никак не могу найти для Dle 11.0. О

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

наверх