Не нравятся результаты поиска? Попробуйте другой поиск!
DLE FAQ » Все вопросы » Общие вопросы по PHP » Перестал работать модуль на Dle 10.4, как исправить?

Перестал работать модуль на Dle 10.4, как исправить?


     06.04.2015    Все вопросы » Общие вопросы по PHP    1510

вопрос
Добрый день! Перестал работать модуль на Dle 10.4, на предыдущих версиях работал. Есть модуль, который подключался в предыдущих версиях через index.php таким образом - require_once ROOT_DIR . '/modul.php'; и $tpl->set ( '{modul}', $modul );
Так как почти весь код из index.php перенесли в 10.4 в engine/modules/main.php то прописываю все это в engine/modules/main.php.
Но выдает ошибку БД Fatal error: Cannot redeclare class db in /engine/classes/mysql.php on line 24.

Ответа пока нет


1 комментарий

dimanbmw
Юзер

dimanbmw - 7 апреля 2015 13:06 -

$tpl->set('{modul}', require_once ROOT_DIR . '/engine/modules/modul.php');

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

наверх