Не нравятся результаты поиска? Попробуйте другой поиск!
DLE FAQ » Все вопросы » Общие вопросы по PHP » Как поправить код под новые версии PHP ?

Как поправить код под новые версии PHP ?


     28.05.2020    Все вопросы » Общие вопросы по PHP    114

вопрос
Обновил версию PHP на сервере и в модуле Showstat от Пафнутия появилась ошибка: Warning: fgets() expects parameter 1 to be resource, string given in /engine/modules/showstat.php on line 160, вот сам код:
$showstat .= "<a id='log-link' href='".$config['http_home_url']."uploads/stat_log.html' target='_blank' title='Смотреть лог. Лимит ".$size."Кб,  сейчас: ".fgets($statfile).round(filesize($statfile)/1024,2)."Кб'></a>";

Ответа пока нет


6 комментариев

dj-avtosh
PHP-developer

dj-avtosh - 30 мая 2020 04:03 -

Проблема явно не в версии php, у вас не передается указатель в fgets, покажите больше кода.

ЯД: 41001679231462
Заказы в telegram (ремонт модулей, оптимизация нагрузок и т.п.): @blob42
В телегу писать сразу задачу и бюджет.

shadow6630
Юзер

shadow6630
Юзер

shadow6630 - 30 мая 2020 09:33 -

Конкретно мой код, так как вносил мелкие правки под новый PHP, вот https://pastebin.com/7xJHcww9

dj-avtosh
PHP-developer

dj-avtosh - 30 мая 2020 19:05 -

посмотрите, существует ли /uploads/stat_log.html

ЯД: 41001679231462
Заказы в telegram (ремонт модулей, оптимизация нагрузок и т.п.): @blob42
В телегу писать сразу задачу и бюджет.

shadow6630
Юзер

shadow6630 - 31 мая 2020 12:10 -

Файл существует, проблема оказалась в другом: переезжал на другой сервер и не перенеслись CHMOD, прописал заново и все гуд

dj-avtosh
PHP-developer

dj-avtosh - 1 июня 2020 22:50 -

практически то же самое

ЯД: 41001679231462
Заказы в telegram (ремонт модулей, оптимизация нагрузок и т.п.): @blob42
В телегу писать сразу задачу и бюджет.

Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

наверх