Не нравятся результаты поиска? Попробуйте другой поиск!
DLE FAQ » Все вопросы » Общие вопросы по вёрстке » В модуле поиска DLE некорректно выводится иконка доп.поля,как решить проблему?

В модуле поиска DLE некорректно выводится иконка доп.поля,как решить проблему?


     11.03.2020    поиск, доп поле    Общие вопросы по вёрстке, Модули, Хаки    54

вопрос
Всем привет столкнулся с такой проблемой, есть доп.поле strana , решил к каждой стране выводить соответствующую иконку (флаг страны) . В общем потоке новостей всё выводится замечательно также при смене категорий либо же пользуясь стандартным поиском dle также иконки в новости отображаются корректно.Но через модуль DLE фильтр который ранее был field search вместо иконок отображается просто кусок кода который отвечает за вывод этих иконок. Иконки вывожу таким способом в отдельном tpl файле:

[ifxfvalue strana="Afghanistan"] <img src="/templates/flags/Afghanistan.png">[/ifxfvalue]
[ifxfvalue strana="Albania"] <img src="/templates/flags/Albania.png">[/ifxfvalue]
[ifxfvalue strana="Algeria"] <img src="/templates/flags/Algeria.png">[/ifxfvalue]
[ifxfvalue strana="Andorra"] <img src="/templates/flags/Andorra.png">[/ifxfvalue]
...


а это строка кода с доп полем и иконкой вместе:

[xfgiven_strana]<div class="short-sec-col short-strana">Country: [/xfgiven_strana]<span>[xfvalue_strana] {include file="icon_country.tpl"}</span></div>


Помогите если кто знает в чём проблема всю голову сломал уже
Версия DLE 13.2

Вот ссылка на сайт aveak

Ответа пока нет


Чтобы комментировать - войдите или зарегистрируйтесь на сайте

Похожие вопросы

наверх